Talk:Deduplication

From btrfs Wiki
(Difference between revisions)
Jump to: navigation, search
m
Line 14: Line 14:
  
 
[[User:Bill S.|Bill S.]] ([[User talk:Bill S.|talk]]) 11:58, 3 August 2015 (UTC)
 
[[User:Bill S.|Bill S.]] ([[User talk:Bill S.|talk]]) 11:58, 3 August 2015 (UTC)
 +
 +
:: The README for duperemove states the requirement "Kernel: Duperemove needs a kernel version equal to or greater than 3.13". Does this explain why it wasn't available for your system? If so, then the wiki is probably fine, though adding something like "Requires kernel 3.13" certainly wouldn't be bad. [[User:Bobpaul|Bobpaul]] ([[User talk:Bobpaul|talk]]) 20:28, 4 October 2015 (UTC)

Revision as of 20:28, 4 October 2015

duperemove not universally available.

The article should note that duperemove isn't available for all platforms all the time. If this means it is appropriate to 'revert' to bedup, noting so (this wiki article being the 'expert') would be useful.

Also, it would be worth mentioning that Ubuntu has a ppa for it / duperemove does not come with btrfs-tools (else one keeps hunting for what one doesn't have, and the new user will be baffled.)

Per http://askubuntu.com/questions/631917/how-can-i-deduplicate-my-data-with-btrfs it would be useful to note that https://launchpad.net/~lordgaav/+archive/ubuntu/duperemove exists, albeit only for trusty (14.04) or later.

Bill S. (talk) 18:52, 30 July 2015 (UTC)

This sounds like too much distro-specific for this wiki. We had pages with distro information but removed them because nobody kept them up to date. We/you can add links to other wikis of course. --Kdave (talk) 10:49, 3 August 2015 (UTC)
OK, fair statement, except, don't forget: The article should note that duperemove isn't available for all platforms all the time. Perhaps kernel version sensitive, which could be mentioned, if so. The impetus for the talk entry was chasing my tail for some time for a duperemove that doesn't exist (for my system). A note that it isn't available for all platforms all of the time would have saved me some time chasing my tail for something the wiki essentially implies is always present.

Bill S. (talk) 11:58, 3 August 2015 (UTC)

The README for duperemove states the requirement "Kernel: Duperemove needs a kernel version equal to or greater than 3.13". Does this explain why it wasn't available for your system? If so, then the wiki is probably fine, though adding something like "Requires kernel 3.13" certainly wouldn't be bad. Bobpaul (talk) 20:28, 4 October 2015 (UTC)
Personal tools